查看: 63|回复: 0

StableDiffusion中缺少torch或者版本问题

[复制链接]

892

主题

940

帖子

3892

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
3892

最佳新人

发表于 2024-6-14 15:12:22 | 显示全部楼层 |阅读模式
近日在启动时遇到了这个问题
提示以下内容

You are running torch 2.0.1+cu118.
The program is tested to work with torch 2.1.2.
To reinstall the desired version, run with commandline flag --reinstall-torch.
Beware that this will cause a lot of large files to be downloaded, as well as
there are reports of issues with training tab on the latest version.

经过实验,终于解决了
以下为解决方案

先在webui-user.bat
中去掉这行
set COMMANDLINE_ARGS= --xformers


然后加上
set COMMANDLINE_ARGS="--reinstall-torch"

等待安装完毕后

再去掉刚刚加上的那个命令

之后在把这个set COMMANDLINE_ARGS="--reinstall-torch"加回来即可

最后如下:

  1. git pull
  2. @echo off

  3. set PYTHON="D:\StableDiffusion\Python\Python310\python.exe"
  4. set GIT=
  5. set VENV_DIR=
  6. set COMMANDLINE_ARGS= --xformers
  7. call webui.bat
复制代码

git pull  这个命令是我后加的,目的是每次更新保持同步GIT仓库上最新版本。你也可以去掉它





关注galaxixv,官方微信公众号。
GALAXIX UE4 讨论学习群 140439020
UE4精英学习群  12762592
UNITY学习群   194092348
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则


快速回复 返回顶部 返回列表